SharePoint Initialize-SPResourceSecurity Attempted to perform an unauthorized operation


Here’s a tricky little issue I struck, so I thought I’d share the solution. In my situation I was installing SharePoint 2013 Server on Windows Server 2012.

I built a new SharePoint environment using AutoSPInstaller. The installer PowerShell script threw an error but continued running until it got to the provisioning Enterprise Search step. At that point I get an endless number of blue dots appeared in the script and it never ends………………………………………

Initialize-SPResourceSecurity : Attempted to perform an unauthorized operation.

I tried running Initialize-SPResourceSecurity from the SharePoint Admin PowerShell (run as Administrator). I received the same error as above.

I thought the issue was with AutoSPInstaller, so I tried running PSConfig only to have it fail with a similar error. The PSConfig log file contained an error with the same description as the one above. It included an additional line indicating the issue was a file system permission problem. This lead me to the solution below.

Solutions:

The solution was to change the “Local Administrators” group permission on the C:\Windows\Tasks folder from Modify to Full Control.

Rerun the AutoSPInstaller or PSConfig and the error should no longer occur.

I hope this helps the next person who strikes this problem!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s